Firefox não suportará plugins baseados em NPAPI em breve

Depois do Google Chrome, agora foi a vez da Mozilla confirmar que o Firefox deixará de suportar plugins baseados em NPAPI (Netscape Plugin Application Programming Interface).

Firefox deixará de suportar plugins baseados em NPAPI

FIREFOX DEIXARÁ DE SUPORTAR PLUGINS BASEADOS EM NPAPI

De acordo com o anúncio publicado nesta semana pela Mozilla em seu blog, o Firefox deixará de suportar plugins baseados em NPAPI até o final de 2016.

Por muitos anos, os plugins NPAPI foram usados para incorporar diversos recursos e funcionalidades ao navegador. Infelizmente, estes plugins também introduziram vulnerabilidades, instabilidade e até mesmo causaram um impacto negativo no desempenho do Firefox.

Com a chegada do padrão HTML5, finalizado em outubro de 2014, diversos plugins deixarão de ser necessários. Por exemplo, o novo padrão permite que conteúdo como vídeo e áudio seja oferecidos nos navegadores sem que seja necessária a instalação de plug-ins como o Flash Player.

O novo padrão também oferece um método para exibição de gráficos SVG e notações matemáticas, enquanto que outros recursos permitem o desenvolvimento de aplicações web que podem ser usadas offline e o suporte para funcionalidades como arrastar e soltar.

Antes de anunciar que o Firefox deixará de suportar plugins baseados em NPAPI, o navegador começou a restringir seu comportamento com a implementação do recurso “clicar para reproduzir”.

Infelizmente, o anúncio da Mozilla não significa o fim do suporte para o Flash Player no Firefox. Assim como ocorre no Google Chrome, o plugin da Adobe continuará a ser suportado no navegador.

via Baboo

Deixe um comentário

O seu endereço de e-mail não será publicado.

Esse site utiliza o Akismet para reduzir spam. Aprenda como seus dados de comentários são processados.